1

New firmware release (12/11/2018) - Apple TV (BLE), Amazon Fire TV, Nest Thermostat

Hi everyone,

We’re thrilled to announce a big new software update for Smart Remote:

  • Smart Remote Firmware v0.66.9
  • Smart Remote App 1.2.9 (available on App Store)
  • Android App 1.4.5 (available on Google Play)
  • Room Sensors Firmware remains the same v0.16.7

Instructions

  1. Update your Smart Remote app to the latest version (iOS and Android)
  2. Make sure your Smart Remote firmware has been automatically updated to v0.66.9. If you need help with this, please go here.
  3. If you previously added an Apple TV, you will need to add a new Apple TV Bluetooth (BLE) device and re-create any AV Scenes that included Apple TV. Then delete the original infrared version of Apple TV from your Smart Remote.

New features

  • Apple TV Bluetooth (BLE) integration is now available for 4th generation models and later. This integration includes a new trackpad navigation feature (just like the Apple TV remote) and keyboard functionality for searching. 
  • Amazon Fire TV Bluetooth (BLE) integration is now available for Fire TV 2nd generation and later, Fire TV Stick 2nd generation and later, and Fire TV Cube 1st generation and later. This integration includes a trackpad navigation feature and keyboard functionality for searching. 
  • Nest thermostat integration is now available. Not supported: Nest Thermostat E Heat Link EU in Europe, fan or home/away functionality or Home Scene creation.
  • AV Scene and Home Scene lists are now available to locate in Point Mode.
  • Spotify is now available to add to Home Scenes.
  • Smart plug groups are now available to create and locate.

Improvements

  • Point Mode calibration is now only done during the initial setup.

Bug fixes 

  • Adding a button through Custom UI disabled another one
  • iOS app crash on item reordering or removing
  • Smart Remote freeze on black screen - IR issue
  • App stuck on "downloading" when adding an IR device
41replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • My remote seems to have problems with the update... 

    It s stuck on the “loading your experience” Page and blacks out after that. 

    I did a hardware reset (with pairing and everything) and for a few seconds it seemed to work, but after that the problems were the same...

    Reply Like
    • Ingo Becker Removing the AppleTV removed the problems! ;-) Sorry to have bothered you!

      Reply Like 1
    • Ingo Becker But again only for a few seconds... I can still connect to the remote, but when I take it from the cradle it a blacked out...

      Reply Like
      • Sevenhugs
      • Sevenhugs
      • 7 mths ago
      • Reported - view

      Ingo Becker thanks for sharing this! Do you confirm that you were able to update the firmware on your Smart Remote and that everything is back as normal on Smart Remote but when you take Smart Remote off the Charging Base there is something wrong? Could you please share any screenshot are described exactly where you are when you see this issue?

      Reply Like
    • Sevenhugs The update process was without any problems. I made all work again - one home scene that included two sonos speakers caused the problem that crashed the remote always when I took it from the cradle. After removing the scene everything was fine - when I tried to add the scene again, the remote crashed again all the time when I took it from the cradle... 

      So I deleted the scene again and everything is fine. 

      Kind of strange but now everything is fine!

      Reply Like 1
  • AV Scene and Home Scene lists are now available to locate in Point Mode.

    This doesn't seem to work. Long press AV-scene results in nothing.
    Am I doing something wrong?

    Reply Like
    • Wout Martens Hello, if you try to locate Home scene or A/V scene one by one it won't work. You can currently locate the list of Home Scene or A/V scene by long pressing the icon of the list in the carousel. 

      Reply Like
    • Kevin If I activate AV scene first and long press the icon in carousel mode it doesn't give me the option to point mode. Nothing happens. Also tried a new AV scene just to be sure but that didn't work either.

      Reply Like
  • OK, I figured it out, which to me is a bit strange UX.
    So you need to longpress the AV mode button (not the actual scene you want to activate) in order to pin. Works now but have to say that this was not very intuitive.

    Thanks for the prompt reply.

    Reply Like
      • Sevenhugs
      • Sevenhugs
      • 7 mths ago
      • Reported - view

      Wout Martens we're glad that you were able to have it work. We'll make sure to share your feedback with our team in terms of UX.

      Reply Like
  • Great update. Had some issues customizing the fire tv (fire stick) remote. My fire stick doesn’t have volume control so tried infrared learning to match the volume up and down to my Roku Tv. It would work during programming but not work after save. Ended up removing the buttons and creating my own with infrared and it works!

    Reply Like 1
  • On also, will there be an option to FULLY customize a device through infrared learning from the ground up? Example, I have a infrared Fan or vacuum not supported. I’d like to build my own remote for these devices. 

    Reply Like
    • Hi Ronnie Potts ,
      Thanks for your feedback.
      Our team is actively working on this feature, hopefully it will be release in Q1 2019.
      Thank you for your patience.

      Reply Like
    • Alex T you guys are awesome! Looking forward to the evolution of this already awesome remote.

      Reply Like
  • I keep trying to add my remote to the Apple TV via BLE, but the Apple TV never seems to find it. Anyone else having the same problem?

    Reply Like
      • Sevenhugs
      • Sevenhugs
      • 7 mths ago
      • Reported - view

      Bill Zanetti do you confirm that both your Apple TV and your Smart Remote are awake when trying to discover it? 

      Reply Like
    • Sevenhugs absolutely. Both devices are awake, and I keep going back and forth on the carousel on the seven hugs remote to keep it awake while the Apple TV is searching.

      Reply Like
    • Bill Zanetti Sevenhugs

      Hello, I have exactly the same issue. 

      I factory reset my smart remote and my Apple TV. I add the AppleTV on the mobile app, then complete the configuration from the remote. My Apple TV is completely unable to see the remote, even if it sees other Bluetooth devices. The Smartremote wait on the Apple TV screen for less than 2 minutes, and reboot itself, with « Loading your experience ». It seems like it cannot activate Bluetooth somehow. 

      Thanks for your support...

      Reply Like
    • Philippe PETER It seems the Bluetooth LE chip on some remotes is faulty. I think we need replacement remotes.

      Reply Like
    • Bill Zanetti ok, that happens, do you know how to proceed?

      Reply Like
    • Philippe PETER contact support. Seems like there is a big backlog because the replies are sparse.

      Reply Like
    • Bill Zanetti Ok, thanks will do. Merry xmas!

      Reply Like
      • Bolu OSevenhugs
      • Customer Care
      • Moboluwaji_Okupe
      • 5 mths ago
      • Reported - view

      Philippe PETER Hi Phillipe, I have sent you an email regarding some troubleshooting steps that could solve your issues, please let us know if it worked, thanks !

      Reply Like
  • Working perfect here. Can you explain the steps you take for adding the remote?

    Reply Like
  • I love the new controls for the firetv.  Is there anyway to add them to a scene?  I noticed that it uses a trackpad button but I can't seem to add the same to my existing scene.  If not is there a way to change the vol up and down on the amazon firetv control to be my audio receiver?

    It is getting better and better each update.

    thank you

    Reply Like
      • Sevenhugs
      • Sevenhugs
      • 7 mths ago
      • Reported - view

      Chris Thro Have you tried to create a new AV Scene with your Fire TV?

      Reply Like
  • That worked. thanks!

    Reply Like 1
    • Chris Thro glad to hear that! Please feel free to get back to us with more feedback, we love receiving feedback from our customers!

      Reply Like
      • Chris Thro
      • Chris_Thro
      • 7 mths ago
      • Reported - view

      Anne-Sophie F. I have a weird issue.I have created a new scene with the firetv. When I turn it on it ends up muting my sony av receiver.  I have tested turning the receiver on and off with the device in the carousel . I have even stopped and started it with the scene repair on the av scene and both work without muting. I have tried deleting and recreating the scene,but it still continues to mute it when I turn the scene on.

      Reply Like
    • Chris Thro  thanks for sharing this! Could you please let me know the model number of your Sony AV receiver? Also, when you say "muting my sony av receiver" do you confirm that it ends up muting the sound of your av receiver but it doesn't turn it off?

      Reply Like
      • Chris Thro
      • Chris_Thro
      • 7 mths ago
      • Reported - view

      Anne-Sophie F.  The model number is Sony SA-WCT100,  I just tested again and noticed that it is muted only after I touch the trackpad after everything has turned on.

      Reply Like
    • Chris Thro thanks for sharing! We shared this info with our team so they can investigate your issue. We'll get back to you as soon as possible.

      Reply Like
      • Chris Thro
      • Chris_Thro
      • 7 mths ago
      • Reported - view

      Anne-Sophie F. Thank you. I tested again and it appears it is not the track pad. After starting the scene if I don't press anything then after about 5-10 seconds the receiver will mute. 

      Reply Like
    • Chris Thro thanks for the update, we'll get back to you as soon as possible.

      Reply Like
      • Chris Thro
      • Chris_Thro
      • 5 mths ago
      • Reported - view

      Anne-Sophie F. Hello, Any update? This is still an issue.  Any scene I activate the receiver starts up muted. 

      Reply Like
    • Chris Thro thanks for getting back to us! Our team is working on this issue. In the meantime, could you please try the following workaround and let us know if that helps?

      • On the Smart Remote App, go to the device (Sony SA-WCT100) settings
      • Open "Customize Screen Layout" menu
      • Add a custom button, select "Use infrared Learning", and give a name (e.g. "on")
      • On the Smart Remote, go to the device (Sony SA-WCT100) screen
      • Click on the new orange button ("on") and follow IR learning procedure to record the right "on" action with the original remote. 

      This change should be reflected in your AV Scenes. Please let us know if that helps.

      Reply Like
      • Chris Thro
      • Chris_Thro
      • 5 mths ago
      • 1
      • Reported - view

      Anne-Sophie F.  Thank you. I finally got around to trying the suggestion and it worked perfectly.

      Reply Like 1
  • After following all of the instructions for setting up the Fire TV cube I am not able to get anything set up. Nothing shows up under the Fire TV Cube Other Bluetooth device section when I select Add Bluetooth Devices. I used the wake word and even asked Alexa to pair to Bluetooth yet nothing is happening. 

    On the Smart Remote app I see No Device Discovered.

    Here are the specs of what I am running:

     

    Device: Amazon Fire TV Cube 1st Generation

     

    Amazon Fire TV Cube Software Version: Fire OS 6.2.5.8 (NS6258/1604)

     

    Phone Device: iPhone X

    Phone operating system: iOS 12.1.2

    Smart Remote App version: 1.3.2

    SevenHugs Remote Firmware version: v0.66.12-19.5.4-ae

    I have confirmed that the WiFi for the Sevenhugs remote and my iPhone are using the exact same network.

    Please help.

    Thank you.

    Reply Like
    • Sam P It looks like you are in contact with someone from our team via email. Please let us know if you need additional assistance.

      Reply Like
  • Hi there, me and a lot of people have asked for the magic remote option. We got an answere that this will be fixed soon. Im sick of the waiting game with sevenhugs. Waited two years for the remote to discover that it has no use @ all. Is this gonna be fixed in the next month YES or NO!!! I will peronaly go to paris to Collect my money back and will give the remote back to you guys. I never been so pissed at a firm that makes to much promises!!! Fix this shit!!!!!!

    Reply Like
    • Bruce De Swaan We understand your frustration. Our team is working hard every day to make sure they implement all devices and features asked by our customers. For LG Tv remote, we were able to fix the enter/OK button but haven't been able to add the magic remote option yet. We'll make sure to let you know as soon as we start it.

      Reply Like
Was this helpful?1 Follow
  • 1 Likes
  • 5 mths agoLast active
  • 41Replies
  • 548Views
  • 15 Following

Still have questions?

Send us an email and we'll help out. Contact us