No Roku or Philips Hue discovered, unable to add them manually


I use emulated Roku and Philips Hue for Home Automation integration.

These software allow my installation to be seen by apps and Logitech Harmony for exemple.

I have an emulated Roku that allow me to map all button to actions in my software, same for Philips Hue (Hue Emulator)





No issue with discover by apps or Logitech, but Smart Remote remains unable to discover any of these.

But my Kodi are seen, so it's not a wifi discover issue.


Any ideas ?

Why it's not possible to add them manually in case discovering is not possible ?



9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • hi   Cédric Dupont , are your two emulators connected to the same network as the Smart Remote? The possibility to manually add devices its a good feedback that you can post and vote for in our feature request section

    Reply Like
  • Yes same network : smart remote, emulated roku, emulated Hue, android phones and tablets.

    The android remotes have no issues to fin the emulated stuff, only the Smart Remote stay blind.

    Reply Like
    • Cédric Dupont  thanks for getting back to us! Concerning your Roku device, the emulated Roku software does not answer to our discovery query yet, this should be solved in one of or next software update, Concerning your Hue lights, it looks like this is on the emulator's side. Our team is investigating it further, we'll let you know if we find anything.

      Reply Like
  • Reply Like
  • Hi, just got my new Smart Remote and it is fantastic. However, I've tried to import lights via a HUE emulator (home assistant) and the Smart Remote app does not pick up any device. The emulator works well because it is seen by my alexa without problem. I've tried to change the emulator port (80 and some higher ports, like 8300 etc) but no joy.  

    Reply Like
    • marcello gallucci  thanks for raising this! We have identified this issue and a fix should be available in our next release, stay tuned! 

      Reply Like 1
    • Anne-Sophie F. Looking forward to this fix, i had originally setup this functionality during the beta trials and it worked great then. Been disappointed that its had issues for awhile now.

      Reply Like
    • Anne-Sophie F. I did notice that the lights i had added (homaassistant using hue emulation) worked correctly still but i was unable to add any new ones nor as indicated above would the remote find the hue device. I deleted all the lights from my remote and still was unable to add new ones.

      Reply Like
    • Dustin Richter thanks for following up, we are a bit late on our next software release but I'll let you know as soon as it's live to see if this fixed your issue. 

      Reply Like
Like Follow
  • 8 mths agoLast active
  • 9Replies
  • 455Views
  • 6 Following

Still have questions?

Send us an email and we'll help out. Contact us