1

Adding Kodi doesn't work (Error 2103513)

I'm running Kodi Leia 18.1, control over HTTP and uPNP (or whatever its called) are both enabled according to the FAQ instructions. The smartremote app recognizes my Kodi device, and it brings me to the login screen where I enter a username and password, but when I click next, on the first attempt I see a blank screen, and when I refresh, I get the error 2103513. See screenshots. 

12replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • hi  Laurens Swart  thanks a lot for raising this issue. Could you please let us know the Serial Number of your Smart Remote as well as the version of firmware your Smart Remote is currently on?

    Reply Like 1
    • Anne-Sophie F. Software version v.0.67.10, serial 905de048b48b260139

      Reply Like
    • Anne-Sophie F. Version v0.67.10-19.5.4-ae to be exact

      Reply Like
    • Laurens Swart thanks a lot, I've shared this issue with our technical team. I'll get back to you as soon as I have news on this!

      Reply Like 1
    • Anne-Sophie F. Any update on this? Can't wait to get rid of my Android Box remote (Xiaomi MI Box which runs Kodi) 

      Reply Like
    • Laurens Swart we are still investigating this issue but I'll make sure to get back to you if we have additional questions or an update. 

      Reply Like
    • Laurens Swart it looks like this is an authenticate issue, could you please try the following steps?

      • Restart your Xiaomi Box
      • Double check in Kodi settings if there is username/password
      • Make sure to fill username and password if necessary while settings Kodi on Smart Remote

      Please let us know if that helps.

      Reply Like
  • Hi Anne-Sophie, 

    I have tried your suggestion. However, it doesnt work yet. I do see an error message now though: 

    {"code":500,"message":"\/rom\/webapp\/resources\/setup.lua:56: attempt to call a nil value (method 'set_params')"}
    Reply Like
    • Doing it the second time gives a blank screen again, and the third time gives an error code once more. 

      Reply Like
    • Laurens Swart thanks a lot for getting back to me. I've shared this information with our team, I'll let you know as soon as we have news on this.

      Reply Like
    • Anne-Sophie F. I just tried it without setting a username and password in Kodi and now it works!! So it does have something to do with the authentication, I can however assure you I entered correct login details (I even tried username 'a' password 'a')

      Reply Like
    • Laurens Swart Thanks a lot for getting back to us, I'm glad that it finally works for you, I've shared your feedback with our technical team so they can investigate why authentication is not possible via credentials.

      Reply Like
Like1 Follow
  • 1 Likes
  • 1 mth agoLast active
  • 12Replies
  • 36Views
  • 3 Following

Still have questions?

Send us an email and we'll help out. Contact us